Installing Scorch and the new Avid viewer


What is the new Avid viewer?



The Avid viewer is a new technology that enables the viewing and printing of scores online without needing to install any additional software, such as Scorch. The Avid viewer is still undergoing extensive development and testing, but we have made it available alongside Scorch because of the difficulty of installing Scorch for some browsers and operating systems, and in particular Chrome versions 42+, which has disabled support for Scorch.

The main limitation of the current Avid viewer is that it does not support transposition between keys. Older browsers may also not display the score correctly. All scores that can be viewed and purchased on Musicroom.com are available in Scorch and Avid viewer versions in both preview mode on the product page and after purchase in Your Account. We welcome your feedback.

Install Scorch on Windows (Internet Explorer)



Internet Explorer will automatically display a prompt to install Scorch underneath the browser address bar or at the bottom of the browser window:





Click "Install" on this message to start the install. If you haven't seen the prompt, just refresh this page (press F5 key). Once the install has completed, please close and re-open Internet Explorer. In certain cases, you may have to restart your computer.

If you're having problems getting Scorch prompt to appear, please install the plug-in manually by downloading and running this file.

In some cases when you have Scorch already installed and you are trying to view sheet music in Scorch format on our website, Internet Explorer would prevent the sheet music from showing and will show this information bar:





If this happens, just click "Allow" button on the information bar and sheet music should appear.

Should you continue to experience problems with Scorch and Internet Explorer, please contact us.

Install Scorch on Windows (all other browsers)



Step 1

To install Scorch on Windows (for Chrome & Firefox), download the install file by clicking here and then click "Run".

Step 2

Once the installation window appears, click "Next":



Step 3

Accept the Licence Agreement by clicking "Next":



Step 4

Click "Next" to install into the default installation folder (recommended):



Step 5

Click "Next" to confirm and start installation:



Step 6

Click "Close" to complete install:



Step 7

Once the install has completed, please close and re-open your web browser.

Warning: In some instances after you install Scorch and then close and re-open your browser, the sheet music might still not be showing. In this case, please re-start your computer - this usually fixes the problem.

Important information about Google Chrome



A recent Google Chrome update (version 42) has caused the Scorch plug-in to stop working. If you have previously installed Scorch and are now presented with a message indicating the plug-in is no longer supported you can follow the steps below to enable it.
  • Type, or copy and paste the following into the Chrome address bar: chrome://flags/#enable-npapi
  • Click 'Enable' to enable NPAPI
  • Restart Chrome

You can also try using our new AvidBETA viewer which requires no installation.

Install Scorch on Mac(all browsers)



To start installing Scorch for Mac, click here, then click "Open" and double-click on "SibeliusScorch.pkg". Once the install has completed, please completely quit (Cmd+Q) and re-open your web browser.

Note
Current release of Scorch is compatible with Mac OS X 10.7 or later, Safari 6 or later, Mozilla Firefox 18 or later, Google Chrome. Not compatible with Safari 5.

Linux users and Scorch



Unfortunately Avid currently have no plans to release a Scorch plug-in for Linux.

Scorch plug-in system requirements



Windows: Windows XP SP2, Windows Vista 32-bit or Windows 7 32-bit or 64-bit, Internet Explorer 7 or later, Mozilla Firefox, Google Chrome, SeaMonkey, 20MB hard disk space.

Mac OS X: Mac OS X 10.7 or later, Safari 6 or later, Mozilla Firefox 18 or later, Google Chrome, 20MB hard disk space. Not compatible with Safari 5.